+ Reply to Thread
Results 1 to 4 of 4

Thread: Morban quest and environment feedback

  1. #1

    Lightbulb Morban quest and environment feedback

    Environment: Camp Landfall
    How was it that these people came to take over and possess what clearly looks like a Storm Legion camp? Would have been nice to have had some info on that in the chat with npcs.

    The Psyche Mystery
    The second 'marker' was really pretty. I want one of those for my dimension!
    OOh, interesting lore snippet there. They were once human!
    Completed fine.

    Soothing Spirits
    All of the spirits had the text box above their head when they spoke, except for the one where you give him a bottle of something. That text only appeared on the chat box, not above the ghost's head.
    I love the fact that there has been a level of detail put into this quest, such as stars appearing around the tree when you give the guy the telescope, and the little story they tell you about the object given.

    One thing would make it better in my eyes, and that would be to edit the questgiver text to include something about how they found out what victim was where, and that the headstone markers had their names on them. That would be all that would be needed, because you have so many trees and several items, and the item really would have to be at the correct tree. Best just to cover yourself by letting the reader know that the ascended had reason to know which tree held which person.

    Completed fine. Nice ring upgrade.

    Hack and Slash
    I laughed when I read this quest. Dubious morality, but I suppose that is what you get in such situations. Even more dubious since the other quest given at the same time ('soothing spirits') says specifically that people will have been made into the flesh trees. I wonder how soothed they will be even with the momentos if we are eating them as well lol.

    I loved the look of the trees, and I also liked how they changed when you chopped at them to remove some of the bark. Might want to change the sword you use for cutting into an axe or something though. The sword looks ill-shaped for the job.
    Completed fine. Nice item upgrade.

    Carnage: Den Guardians
    Their corpses of the wisps don't appear sometimes unless you move the camera. Also, one time it died and was still quite high up, but the sparkle for the loot was on the ground, making it impossible to collect.
    I applied Disabling Shock to them (harbringer talent) that stuns for 5 seconds. It seemed to apply fine (debuff on it) but it continued to cast its summoning.
    Completed fine

    Death of an Artist
    Completed fine. Almost forgot to scan the body (again), but remembered just before I took the teleport out lol. Been staring at the screen for too long perhaps.

    Carnage: Clearing the Den
    Completed fine

    Torched Canvas
    Completed fine.

    Great Works
    I didn't find enough while going through the area naturally, so ended up having to go back and trying to find more. Got it done in the end though.
    Completed fine.

    Environment: Den of Lezul
    Really liked the look of this place. Very well done inside. I felt that the main chamber could have done with having Massive works of art in it. It seemed too spartan for a creature who takes delight in its art. I would have expected to see several huge pieces, or indeed the entire place carved out of flesh into intricate trees and sculptures.

    Traversing through the den was long. It could have benefited from having been able to use your mount inside.

    Escape Artists
    Completed fine.

  2. #2


    Take the Challenge
    Completed fine.

    Eye Spy

    I had trouble finding these, which was perhaps the point, but their names don't show above their animations. Makes them hard to find. I ended up just making a macro to counter this, but it shouldn't be that needful to do so, because if named friendly npc have their names showing, then the 'friendly' spy droids should be able to as well.
    Completed fine.

    Blast Away
    Completed fine

    Environment: Arlan's Challenge
    I was really surprised at how little was being asked of me at this camp. Three quests and that was it, then moving onto another camp. It seems like a camp this size would have far more needing to be done, even if it was just building barricades or something.

    Under their Noses
    Completed fine

    Opportunity Strikes
    Worked fine.
    I would say however that I was in the middle of the Stormhold when I finished the quests and the disguise ran out of time. It seems silly that the disguise, which was able to be put on several times during the quests, now you cannot use. This means you are stuck in the middle of the Storm Legion Stronghold without a disguise. It was.. interesting, getting out again.

    The quest completed fine, however the reward item had a level requirement on it. If the person is able to do the quest, I say let them have the reward. As a level 55, I was unable to use this reward.

    Intention? Deception
    Interesting concept, good tactics so long as I don't get caught lol
    Worked fine and completed fine.

    He did What?
    Again, I like the concept. Shows thought has been put into these quests. This looks to be a fun trip.
    The quest was interesting, as it had looked to be. I liked the fact that you had to get the right combination of comments to make the person do what you wanted.
    Completed fine.

    Dropping the Storm Wardens
    This quest was confusing. All the other quests given at the time allow you to be in your disguise, however this quest wouldn't work when in the disguise. And they totally killed me when my disguise ran out and I finally managed to hit them because the rocket launcher didn't actually take away all its health, only most of it. I had to shoot again, and by that point, I was dead. Even trying the second time after I had ressed, the rocket launcher didnt take away the full health. I was 1/6 health when it finally died. Not good.
    Completed fine.

    Artifact item: Encounter The Wild: Savages
    This artifact has no proper tooltip, and does not fit into the artifact lists. All it has is the icon on the item, and the Blue writing.

    Shuttering Production
    I am not entirely sure I agree with the Overseer's observation that Dysolt is a monster for putting people's souls into cyborgs. I mean, if they were crippled and wanted to fight, wouldn't it be good to have a body you could use? But perhaps I am missing the point.
    Completed fine

    Elder Shaper Mutilix
    Completed fine

    Target Acquired
    Completed fine

    Circuit Shorting
    Completed fine

    Victory Lap
    Completed fine. Glad to see that there are more quests in Arlan's Challenge.

    Birth of an Artiste
    An interesting concept. It might be nice to have a little bit of information about the Anixtrico stone in the quest text, just so the player knows what they are using.
    This was an interesting quest, taking you from person to person as well as bringing up interesting lore ideas about what happens to people in such situations.
    As with other quests, the quest reward was levelled here, and because I was too low level, I couldn't use it. This is becoming a really annoying feature.
    Completed fine.

    A Dark Past

    Major Kwell doesn't have the text floating above his head, just on the chat log.
    Mayor Gura also doesnt have text floating above her head, just on the chat log.
    Completed fine.

    Environment: The Northern Ruins
    Fell inside some manner of corruption tree/thing and couldn't get out again. 14488,5506

    Ruins Restoration
    It seems like a strange thing to do, but it was some light relief. Seems a pity to leave it in a town of ruins where no one will see it.
    Completed fine

    Tracking Kwell
    Completed fine.

    Carnage: A Grim Tale
    I wouldn't have been able to do this quest without Arlan to tank for me. The mobs here are level 59, and I am level 55. But with him tanking, I got it done fine.

    Into the Monster's Lair
    Okay, there is one big flaw with this. If you die, this quest fails, and Arlan disappears. When you res, even at the res point, you are still in the middle of this lair, and since the mobs are higher level than you, and the area is so large that they have all respawned, it means that you are stuck in the middle of the lair, without the means to get out again, even to pick up the quest. Add to that that the map doesn't show the underground layout, only the overground, and you have one really frustrated telaran. I managed to end up at the deepest point of the lair, and the only way out was either to die and res and keep ressing till I inch my way out, or teleport out and run back to the start again to pick him up.

    Did I mention the mobs respawn way too fast? Killed two mobs, and by the time I got back to the start, all the mobs had respawned again. Rage. I know this is partially because I am too low level, but it was working fine until Arlan didn't tank a second mob and there are places where you have to take two mobs at a entranceway. So frustrated! I just wanted this quest done.

    After a full soul worth of dying, I am giving up on this one for the moment. It just ain't happening.
    (still working on this, will come back to it if I get to a higher level)

    From Kwell, With Love
    (still working on this, will come back to it if I get to a higher level)

    Environment: Den of Kwell
    This place is really looking super.

    Burial by fire
    Completed fine.

  3. #3


    Worldly Possessions
    The item at around 13095,4696 is unclickable, it sparkles, but you can't collect it. This means this quest cannot be completed.

    Carnage: Art Critique
    The artisan flesh trees seem to be overstretching their natural limits, because many areas show as targetting the trees, while they are nowhere near, as if their invisible limit is far beyond their branches.
    Also, when you kill the tree, it doesn't seem withered like in earlier quests. It would be a nice touch if it withered before disappearing, rather than merely staying the same before despawning after death.
    Completed fine.

    Environment: Forest of Flesh
    Tree at 13305,4807 is not seated properly in the ground. You can see the black of its underside when riding past.

    From Kwell with Love
    Completed fine.

    Carnage: Kwelling the Abominations
    unable to finish because I can't find the den of kwell entrance again.

    Into the Monster's Lair
    unable to finish because I can't find the den of kwell entrance again.

  4. #4


    Carnage: Kwelling the Abominations
    Completed fine.

    Into the Monster's Lair
    Okay, finally got this quest completed. There were several main problems with it, some of those I have put in earlier posts, so I won't reiterate on those.

    The one that I will mention here though is the fact that if you struggle with a quest like this, perhaps because you are too low level to completed, your quest ends up being 'failed' in your log. Now, foolish as it might have been, I abandoned this quest, intending to take it up later when I had levelled, except I had extraordinary trouble finding the place again. I spent a good half an hour running around the area trying to find the entrance but to no avail. I see today that the entrance has been put on the map, and perhaps it was before but somehow I never spotted it. Either way, i think that if a quest like this is failed, the location of the questigver should be put on the map, so that players can easily find it again from the 'failed' quest. This is especially important since it was a chain quest. It might also be useful if there was an npc that points to the correct location of the npc, if you had abandoned the quest for some reason, otherwise people may not be able to find the location of the quest chain again.

    Other than that, I ended up teaming up with another player to do this quest, so with the two of us, and the two of the npcs, we didn't exactly have any problems. It completed fine.

    One other thing about this quest. When I was travelling to try find this, there was a quest marker showing here: 13341,5297. There was no quest above ground, so I marked the place and figured it was in Kwells den somewhere. When I got to the position, the only thing that was there was a res point. When I went back after I had completed the quest to check it out again, the quest marker was gone. I can therefore assume that it was a phantom quest icon from this quest npc, since the actual questgiver was about here 13857,5048. Figured you should know.

    Brains and All
    Didn't have any problems with the quest. It was good that there was some time between the skills appearing and the boss turning up in which to read the icons.
    I wasn't aware that the Shapers had been here for thousands of years, I thought it was just hundreds. That could be my error though.
    Completed fine

    Environment: Kwell's Den
    One thing I noticed was that when you killed the boss you couldn't see the teleporter from where you fought him. It is quite a long distance away, so it would be better to either move it forward, or increase the distance it was able to be seen at. You really could use being able to have mounts in here to.

    A Deeper Sleep
    This seemed to work fine. They didn't appear to be 'sleeping' though when I got there. It might be better to show them as being more visibly asleep, perhaps some zzzs or something, I don't know. I also found it odd how they didn't attack me if I messed up, surely they should notice? Of course, it works in my favour for them not to.
    Completed fine.

    Carnage: Scraps of Death
    Completed fine.

    Carnage: Stalking the Gore
    Completed fine.

    Do as the Morbans Do
    I'm not entirely convinced this quest worked like it was meant to. I would toss the meat onto a skeleton, and most of the time it would work, and the mob came up and attacked it, which was fine. Other times the skeletons would already be 'affected' by the meat, even if they were not being attacked. Other times I would be running and one of the mobs would come from under the ground to attack me. It wasn't really a big problem, since I was level 60 and had a friend with me, but it might be an issue for lower level players. Perhaps it was intended this way, since we are carrying the meat. Not sure.
    Completed fine.

    Carnage: Flesh Hulk
    Completed fine.

    Carnage: Flesh Dominators
    Completed fine.

    Feeder Eggs
    When in a team, your teammates do not get the quest item for kicking the eggs ticked off if another member of the party does it. This means that it takes a much longer time to move in an area because if you are in a party, you are having to do the quest several times.
    Other than that, completed fine.

    Carnage: Bone Minions
    Completed fine.

    Mobs: Shapers Citadel
    The passive mobs agro if a red mob runs through them to me. This wouldn't be an issue except that you cannot tell if there is an underground mob around without constantly tabbing. It would be better to either show their names under the ground, or have some sort of dust animation to show roughly where they might be. At the moment they only show the dust when they agro on you.

    Battle in the Citadel
    This was odd, because you could see Arlan beside you, and then directly ahead in the chamber. He shouldn't be able to be seen in two places at once. It would be better to have him run into the chamber first ahead of you.

    I did this quest with someone else, and so I am not sure how well one person would deal with all those mobs, especially if they were below the level of the quest. Being level 60, I lost half my health with my party member backing me up, but then I did stand right in the middle of the mobs. Difficult to say.
    Again, when handing it in, Arlan is in two places at once.
    Completed fine.

    Shapers End
    This quest is seriously bugged

    Being in a team, we had a problem with this quest. It let me go into the gate, but my friend could not get in the gate, either with me in or out of it. In the end, we had to abandon the party and do the quest seperately, then re-party afterwards.

    Even as a level 60, I died to these mobs, even taking them singly. And when I respawned to get back in, it wouldn't let me into the instance (my friend had the same issue on his try) it says 'You cannot enter another instance of this map yet'. So, you can't get your corpse, since it is inside the instance it wont let you in. When you go 'return to graveyard' it takes you to the entrance of the area 15235,5502 but there is nothing to resurrect with. So you are stuck a ghost.

    I ran around the world for quite some time trying to find an alternative res point, since that place didn't have a res guy, and in the end I had to use the 'im stuck' button. This took me to another res point and I used the res guy there to res.. but it ressed me back at 15235,5502 with res sickness and two big mobs instant attacking me. I died again. Thankfully this time the ressurect button took me to another place, one that was safer, but there was no medic to heal my soul with.

    In the chamber, the only one of the powers that works initially is the Memory Recall - veil which isn't exactly useful against the hard hitting mobs. None of the 'helpful' npcs heals me either, which is inconvenient, because the heals I have as pure harbringer just don't cut it, even when single targetting. The mobs don't tend to stay agroed by the npc either, because I had a second mob attack me when I had not hit it.

    All in all, I would say that this is way too difficult for one person to accomplish as it stands right now. I think that some people with certain specs could do it, but as a chain quest, it needs to be universally completed with some work. At the moment, I don't think that is the case.

    Oh, and I went back with a spec that was pet tanking and healing heavy, and it wouldn't let me back into the instance. Said that, once again 'You cannot enter another instance of this map yet'. This quest needs a slap.

    Needless to say, I have not yet completed this quest. My friend did, and he said it was seriously difficult (third time lucky for him).

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts