+ Reply to Thread
Results 1 to 13 of 13

Thread: City Core & Eastern Holdings Quest feedback

  1. #1

    Lightbulb City Core & Eastern Holdings Quest feedback

    City Core

    Into the Trees
    Worked fine

    Ruined in a day
    When I got the last body, the quest auto-completed. This is usually fine, but it didn't give you time to actually read what was written on the quest when you clicked the body. I would have liked to have read it.

    Carnage: Grave new world
    Worked fine

    Dread Mesages
    Worked fine

    Boom Boxes
    Completed fine

    A Fine Mess
    Completed fine. I like the talk with Salvarola, quite eccentric.

    Savage Trophies
    Completed fine

    Roll Call
    I ended up finding the quest after this "Lost in the Shuffle" before completing this one, which was a bit odd since I wasn't actually doing anything with the bodies (ie for burial). Still, the quest ticked off fine.

    Carnage: King of the Jungle
    Completed fine

    Carnage: Cankermaw
    This quest surprised me, since it was only one creature and I hadn't realized he was a quest one before then, since he looks the same as the others at a casual glance. Nice surprise of an extra Empyreal Sourcestone.

    Lost in the Shuffle
    This is a good little quest. It led me around an area I didn't know, which would help me not get so lost in future. It also happened that I ended up having to take on a planar foothold to continue the quest, which was good fun as an aside.

    Environment: Citizen's Library defence point
    I cleared this point of mobs when I went to hand in a quest, and by the time I had gone in, handed in the quest, dumped jumk off in the vendor, I came out and the defence point was taken over by a foothold and at least 10 invasion mobs. Fortunately, I was able to climb up the wall and avoid them, but I wasn't really sure that many were meant to take over that quickly. It seems a little extreme. By the time I had climbed over, less than a minute later, most of the mobs had despawned, leaving only the foothold and three groups. Might be an issue with the spawning of invasion groups there since there was only one guy doing the thing.

    Eyes on Target
    The area you have to stand on for the position around 6980,8510 is not that clear. I stood under the large vine for a while, not understanding why the thing wasn't triggering, until I remembered that this was the area that I had seen on one of the previews given by Trion that had the guy on top of the vine. Only when I got on top of the vine did I see the sparkles there. It would be better perhaps if the place where you were to stand was highlighted in a beam of light, and the place where you were to put your vision on only showed once you were in position. The second gear pack was pretty obvious to see. The scanning for the captive however was not obvious. I managed to find an excellent spot assassins creed style at 6989,8447, or indeed, atop the plant at 7008,8435 that would have been perfect, but it wasn't the spot you have picked out and so wouldn't work. That was kinda annoying. It would have been better if you could pick your own spot as long as it was within distance to the target. More fun to. When I did finally get to the position, (the first one I used) I found that it was difficult to target the cage because of the small hill. All in all, I felt a bit smug that I managed to get closer without detection and get to see the cage better, but on the flip-side kinda annoying not being able to use that lol.

    Environment: Floating artifacts
    There are two floating artifacts underneath the bridge hanging in midair. One is at roughly 6972,8445 and the second one is directly along from that. There is no way to get at them. I expect they were meant to be on top of the bridge, or on the edge of it and have.. umm.. slipped.

    Terminal Path
    I like the idea that this quest brings in terms of it leading you along a path. However I think that the method of execution could be better. You are meant to be following a bloody path, but the path is a bright yellow arrow trail. It would be better to be perhaps red footprints instead. Also the quest sounds very much, in its completion, like there should be a follow-up quest to kill a certain number of mutants, and yet no quest exists. It seems unfinished.

    Guise of Savagery
    Quite fun, I think one of the terrormaw pets might have been able to detect me if I had stayed in its aoe, but never stuck around to find out.

    I came to Drop Bombs
    Seemed to work fine. I tested the terrormaw pet's aoe, and it does take the disguise off you. Interesting. You get a few seconds to get out of the aoe, which is time enough I think

    A Race to Survive
    This was interesting. It would have been better if Salvarola had actually called his pet, or done something more obvious to call him such as "Meet my pet, Prince Kaliban" or "Come Prince Kaliban, meet the ascended!" . Even just one more line of text would do it. It was also a bit frustrating having to keep so close to Belarus since the ascended can run so much faster. Also, if there was a little pause by Belarus at the edge of the platform where he looks back and then says about jumping, giving the player more time to react, it would be better. I missed what he was saying, and the visuals of him jumping is so fast, one second he is there, then gone. If pausing isn't an option, then maybe make him jump a little slower initially? I don't know. Just a little tweak would polish this quest.

  2. #2
    Eastern Holdings

    Nothing Besides Remains
    This is also, like 'Yesterday's News', a good quest to get to know the lore. I noticed that 'explore the main bridge' part of the quest didn't actually finish when you read the plaque, but when you got to the area where the plaque was. Reading the plaque was optional. Not sure if this was intended.

    Yesterday's News
    I am enjoying this quest. Exploring an area, and a story is good fun. I also have found that running along rooftops is fun to.
    The holovoid around the area of 7568,8321 runs a little fast to read comfortably. I had to go back and read on the chat log.
    I ended

    This didn't work out so well. I went down to the bunker and killed the bunker hunter. This freed the captive, but because I killed it from a distance, it didn't trigger in the quest, leaving it unfinished. I did go back later and manage to complete it when it had respawned.

    Environmnet: Reservoir area
    There is a stone/marble type stairway at about 7628,8619 that is really squint. If it had fallen by subsidance, there would surely be more obvious damage to it, and some more boulders beside it etc. It looks too pristine even though the surface is cracked up on one side, all the stairs are technically intact. Not sure if more was going to be added into this or not, but it looks odd as it is.

    Serving Woman

    First thing is that there is no visible smoke signal that I can see from that distance. Even when nearing the area it isn't nearly as visible as I thought it might be. Perhaps if the smoke were a little darker? Still, up close it looks impressive and that is the main thing, I guess.
    However, as others have noted, the quest doesn't trigger when you go there, nor does it when you speak to the princess. Its stuck and there is no way to continue the story.

    Environment: Avendrus estate area
    I noticed, when trying to find other quests in the area to test, following the fail of the last chain one, that the huge rock formations suddenly popped into existance. Rocks around this area 7655,9283 for example should be given a greater distance to spawn, because something that huge shouldn't appear so abruptly near a player, unlike smaller rocks. It is like they have been smaller rocks and just enlarged, which didn't change the distance they showed at.

    Monitoring the Situation
    This quest completed fine

    Exotic Flora
    This quest was fine to do, however it felt like there should have been a follow-up quest for you to hand the samples to an alchemist. I mean, the ascended would either have to dump the things he has collected upon completing the quest, or be carrying them around indefinitely. Oh, I know they are gone from my pack, but even if it were notes, he should really hand them to someone. Another quest added onto this one would be much better.

    Environment: Villa Orphela
    Got a bit of a shock here. Level 55. Ouch.

    Letter Home
    I found this difficult to get to. Suddenly the mobs were level 55, and I was only level 51, having souly levelled up via quests. Still, after remaking a spec to have a ton-load more healing, I managed to kill the one mob camping this quest. It handed in fine though.

    History of Villa Orphelia
    This quest sounds nice, it finishes nicely, however there is only 'Text 1', 'Text 2' and 'Text 3' . The story hasn't been added in here, and there is no text other than the reward on the completion popup.

    Holovid History
    Didn't complete this quest due to high a level, sorry. Will come back later if I have time to level more.

    Environment: Arkella Estate
    There is a herb stuck to the side of a cage at around 8274,8962

    Environment: Southwall Bunker
    Gods, I had such a hard time finding the entrance to this! I was all around the place. Got lost in the commons and died from mobs, then died from falling too far and ended up porting back home and getting a port back to this area, then went into Arkella Estate thinking the entrance must be in there. No wonder its a safe haven, not even I could find the entrance for so long!

    Teleport Tally

    Didn't complete this quest due to high a level, sorry. Will come back later if I have time to level more.

  3. #3
    Senior Member
    Join Date
    Nov 2010
    Ottawa, Canada
    I think they've made the level jump so fast because if you want to ONLY level through quests, you may want to go back and forth BOTH continents, doing all the quests in each.

    Otherwise, except to level some through dungeons/raids/chronicles/IAs/grinding/rifts/events/and so on.

    I think this is fair and a good way to stagger out solo leveling. Imagine doing all of Dusken and being Lv 57ish for Brevane? Half the continent will be significantly weaker than you.
    Maelode, Lv 22 male Eth Mage, Pyromancer(main)-Dominator(sec). Secondary role of pure Chloromancer(healer).
    Maelad, Lv 20 female Dwarf Rogue, Riftstalker-Bladedancer(even) solo. Alt role as pure tank Riftstalker. Just got Marksman, not set in.

  4. #4
    Also found that I'm under levelled for the quests after I tried to pick up the quest chain after the broken quest. I completed some carnage quests and am still searching for the correct quest to pick up after the Serving Woman quest.

  5. #5
    Maybe if there was some manner of quest cross-over that sent you to the other continent when you hit a certain level or something. Like you got status updates from Asha Catari to where you were needed when you are certain levels, so that players know where to go to level up via quests.

  6. #6
    Junior Member
    Join Date
    Oct 2012
    Quote Originally Posted by Demus View Post
    Also found that I'm under levelled for the quests after I tried to pick up the quest chain after the broken quest. I completed some carnage quests and am still searching for the correct quest to pick up after the Serving Woman quest.
    I'm stuck on Serving Woman as well, being a story quest I feel a little dead in the water. My guildie said he was able to complete it and may have to do with someone else trying to do it at the same time. Not sure.

  7. #7
    Quote Originally Posted by Irishae View Post
    I'm stuck on Serving Woman as well, being a story quest I feel a little dead in the water. My guildie said he was able to complete it and may have to do with someone else trying to do it at the same time. Not sure.
    Ended up going to the other continent for now. The Princess is in a bunker north of the quest as well, she gives you another quest for finding portals.

  8. #8
    Join Date
    Oct 2012
    Birmingham England
    these 2 zones seem to have no one doing IAs in them, makes me a sad bunny.

  9. #9


    Serving Woman
    This quest now works fine, although once I had saved her, she did run too fast for me to keep up. When she then disappeared near the bushes, I thought I had lost her because my run-speed was too low, but she just turned into a quest handin. Phew. Still, she did seem to disappear a good ways from where she appeared, one side of the bushes to the other, a good length and a half of a person, maybe more. Might be worth having her disappear where she is to stand, rather than that far away. However, it might just have looked that way because I was too far behind. She really did run fast.

    The Lottery
    Ah! Now I see that my previous worries over the location of this place were unfounded, since the quest chain leads you right to it. Times are obviously difficult, for the princess seems to have lost her trousers. They sent her out with boots and underwear. Poor thing. Oh, no wait, she is wearing trousers, they are just light enough I thought they were skin outside. lol.

    Environment: Southwall Bunker
    People have been surviving down here? Where are the beds, the cooking facilities, the everyday things that people accumulate? There is nothing down here except crafting facilities. Even if they came with nothing, they would have scavenged things to sleep on, things to eat etc.

    It also made me wonder; what was this used for before it was taken over as a refuge? They have a forge etc in there, so I can only assume that it was some manner of crafting area, but why would that be located outside the town walls? There should be some manner of logic to these things.

    Activation Station
    Completed fine

    Port Authority
    Completed fine

    Watch and Learn
    I liked this quest. I also liked that once in a while the following person would say things like I am sure we have all heard in dungeons at one time or another. It did sort of annoy me that the woman would run forward whenever I started attacking, as this sometimes pulled more mobs than the one I was intending (and ended in my death). Might want to have her dance at your side, rather than run behind the mob, although she could get hit by a cleave there. Maybe even waiting a few more seconds before running behind the mob would be best, that would solve the issue.

    Serving the Survivors
    Completed fine.

    Carnage: Trap Play
    Completed fine.

    Carnage: Clearing the Overgrowth
    Completed fine.

    The Lost Locket
    Completed fine

    Sparkles hanging in the air in front of a tent for no reason at 8834,8333. On closer inspection, they disappeared when I clicked the cage door nearby for the quest 'unleashed!', so the two sparkles are linked. When opening the one around 8923,8228 the same thing had happened, with there being the sparkles on the gate, and the sparkles hanging in the air nearby. And at 8682,8148, so it is likely I just didn't see it on the first one. Seems to be affecting all of them.

    Hermit Hole
    This was interesting and fun. I liked his response when you got there. I also liked the round-about way it led you, which is right up my alley

    Long Lost Lovers
    Completed fine. I liked the fact that there was a follow-up quest from Hermit Hole.

    Carnage: Ignoble Savages
    Completed fine

    Environment: Western Commons
    I really love the building style of this place, especially when teamed up with the invasion of the life forces. It really is lovely in it's own way.

    I also really liked the little touch with the fountain memorial of the founding of Brevane. However this fountain does look like every other fountain in this area, so other than the talking pedistal, there really is nothing unique about it. More should be made of this perhaps.

    I am a little concerned over the spawning of the satyrs though. The mutants were mainly grouped around their huts, and the animals graze as they will, but all the satyrs seem to be spawned as guards. They stand in the same spot, or wander the same bit of stone back and forth. What I mean is that they have taken over this expansive city, and if there was some sort of core leadership, I could see that there would be guards around the outside areas, posted as these mobs are. But there doesn't seem to be anything like that. It just seems that ALL the mobs are doing this. None of them are talking or drinking, or any of the other things that we have seen satyrs do in the past. This whole area just seems sort of spawning 101, and it isn't really that inspiring. You don't feel like you are going into an area that is taken over by another culture, just taken over by a hostile force. It would be great to see the satyrs doing more than just standing around looking angry. There is far more to their culture than that.

    The entrance/doorway at 8603,8175 is graphically bugged and appears pink and purple pixles
    It occurs to me that there are huge areas of this estate that seem just like barriers rather than functional spaces. Huge bits of wall that seem to serve no purpose and have no doorways to the areas behind them. With a wealthy estate, some grandstanding is probable, but a little more functionality would be great to see.

    Fell down inside a 'building' at 8583,8169 where several building sections met and into the building at 8568,8153. Dropped down between roof pieces and into what seemed to be a building, but sadly, I was disappointed with the interior lol Other people will likely find this to, since I had travelled up to those rooftops to get a visible artifact there.

    Tile sticking out of a wall on the ramp at 8499,8599

    Environment: Strozza Estate
    I very much like the attention that has been put into the Strozza Estate. The broken bits of furniture, the fact that buildings actually look lived-in, and indeed the fact that there -are- buildings where people live. I also like the fact that you can enter some of the buildings.. though where are their doors? And for that matter, where are the toilet and bathing facilities?!

    One thing about the piles of rubble I see around the place (very good, I like that) is that there are some gold and jade sculptures of a womans face, and yet there are no buildings around here WITH those on them. They seem a bit out of place. I know they are supposed to look as if they fell off a building but none of the architecture around here has them on. They only appear on the ground, and don't appear to have been dragged from elsewhere as loot.

    The building at 8796,8131 that you can get into has bits of other building's walls in it sticking out.
    Like the area with the satyrs, I would have liked to have seen a little more creativity in the spawning. Sure, some of the adepts are standing in doorways, but there must be more to their lives than this.
    There is an artifact hanging in mid-air on top of a low fountain 8878,8273

    The building join at 8906,8131 do not fit together tightly. There is a gap you can see through.

    Plant hanging in mid-air at 9171,8000 and 8627,7561

    Having completed the quest 'Hermit Hole', this final location just typifies what I have been meaning about the large-scale buildings around here. There is no real reason for this tiny building to be up here, other than perhaps as a guard post of some sort, or a top entrance way into a building beneath. And yet there is nothing here. No trapdoor or stairway, and indeed, nothing in the building that shows he lives here, which he clearly is meant to. I know that it isn't finished yet, and I shouldn't judge this too harshly, but it is the small details that count.. and the big ones that keep slapping me in the face. Do these people just build walls several houses-deep?! It hardly leaves any space for people if this were so. When building a town, having usable realisitic use of space really is a must in my opinion. We need more of it here I think. If these huge walls are for defence, why have they not got guard posts or visible defences or the remnants of ones?

    Also, people in general like space to live, and if they are limited by the size of their house in terms of square footage, then they are likely to go up or down to gain more. This can be seen in the Netherlands where house prices are based on how much square footage the house takes up on the ground, not the number of rooms it has, so you often have buildings either several floors tall, but very narrow, or others that also dig deep into the ground. On a rocky hillside like this estate is, you would think that more would be done for general housing to have more space. You have houses here that are no bigger than the small stores we saw back in other towns.

    I really, really want to get into the main buildings in the center of the top teir of Strozza Estate! And then I want to pick them up and put them in a dimention!

    I like the fact that the tree has been mutated at 8802,7520 and elsewhere by the plantlife now growing. Nice!

    I don't much like that the huge vines in the world are very blocky looking. If they are smaller, they scale not too badly, but I think that large vines that you can ride along should really have more 'sides' so they appear rounder, as right now they are very clunky and unappealing. Not at all organic looking. There is only so much shading can do.

    If you stand up against the wall adornments at 8621,7792 you get to see inside the building structure. I can only think that this is true for other bits of wall as well.

    The join between the stairway ramp and the side of the building, although seemingly filled in, actually just drops you into a hole beside the ramp at 8795,8020

    Carnage: Alchemical Peel
    Completed fine

    Worked fine. At one point the mob did go entirely undamageable, not sure why. He didn't appear to be casting or have a buff, but I could have missed that. It was just before he called the two mutants. The mutants disappeared once he was dead after a short time of fighting them, not sure they really should have. Unlike demons or something, they are of this world.. kind of.

    All natural Ingredients
    Not sure if this was a forager-only quest, but I don't believe so. But if it is for everyone, you should possibly put in the text about what people are to look for. From a story perspective, someone who has not got foraging experience would as likely bring back peacebloom as anything poisonous.

    It would be good if the plantlife we need to collect shows up for foragers on the minimap when that part of the quest objective is active.

    There didn't appear to be very many of the thorns active. The area they are meant to be in shows to be huge, and yet I mainly found them clustered around the southwestern part of it, and I had to wait for a respawn to get the last one I needed. You might want to up the amount that spawn for this quest so that people are not hanging around waiting for a spawn.

    I liked the fact that the glands were on every beast, rather than having to kill several just to get one. The vials I saw, of the two that were close together, one always spawned when the second one was taken, so this made it easy to pick them up.

    Environment: Reservoir
    The bits of wall such as those at 8114,8560 don't seem to be part of any of the same architecture as the rest of the area. They don't seem to be made by the plantlife taking over the area, nor do they seem to be of the same time as the main buildings, and yet they could not have been earlier. The only thing I can think of that they might bear some resemblance to is bits of the huge freeway that roams the land, and the metal has been eroded over time. If this is so, then actually seeing some of the details on these bits of structure would give them far more of a sense of place. And yet, I see bricks showing through on pieces.. not sure what to make of these.

    Also, on the map, around the same area at 8064,8541 and 8081,8522 there are two white pillars of some kind, possibly related to the bits of wall/road being used as defences? but they are not actually showing in the world, or the minimap.

    Switching Bait
    This worked fine. The reward was also the first bit of gear that was actually better than I had already, which is nice.

    Light it up, Tear it down
    This worked fine. The only slight snag was with the bottles of fire as unlike the totems, they did not disappear after use, or rather, perhaps they did, but they respawned. You could only click the same one once, which is good, but you could still SEE the ones that you had previously clicked looking like they should be sparkling lol. Just a minor niggle really, not really a bug.

    Lair of the Beastlord
    Worked fine

    Environment: Lair of Thetormon
    I like the interior of this, however the fact that there were only completely filled bookcases is a bit of an oversight. Bookcases tipped that much would have had books fall from them, and indeed, after having a beast climbing around in there, I am sure some of those bookcases and books would have been visibly damaged.

    Survivors at Arkella
    Completed fine

    Environment: Arkella Estate
    Random beam of light coming from the ground at 8288,8976

    The small barn at 8375,9209 is showing as fallen into the ground. If it was a mud-slide I could understand, but it has fallen into what appears to be rock, and all its roof is still intact, nothing is out of place except for the angle it interacts with the ground. It looks pretty wrong. More love and attention needs to be given to this barn to make it appear broken.

    Jumped down to here 8536,8954 beside the stairs and dropped through seemingly solid scenery. I was thereafter able to walk through the stairway. The blocking beside the stairway is not solid and should be. Also the doorway at 8539,8958 has a bit of hillside sticking through in the middle of it.
    The flat bits of grassland above the Arkella estate are surprisingly free of anything, like widlife etc.

    Arkella Tales
    Argh! This place is a maze! Trying to find my body again is horrific.. 10 mins later: this place should come with an insanity warning. Still trying to complete a quest in here. Yeah, I am a bit under-levelled. Will need to come back and complete this later. Level 53 does not do well here. I keep forgetting I am not playing rogue while on my mage-harbringer and that I cannot therefore disappear at will.

    Savory Survivors (edit: not sure whether this was actually called this, and misspelled, or if it was actually Savoury)
    Found this quest fine. It has the same gate-bug as the 'Unleashed' quest, where there was a second sparkle hanging in the air nearby the gate.

    This quest didn't complete. It shows as completing, and the popup beside the mini-map with the loot reward turns up, however when you click 'finish' nothing happens, the window shuts, and you still have the loot icon beside the mini-map.

    This bug also stops you from getting the rewards from any further quests that give loot when you complete, because they are stacked with this one coming first.

    Environment: Fen Gorge Bunker
    I liked the rocky outcroppings, they were interesting. It makes sense that spiders would come here, but it does seem like this area has just been started. Spiders webs to make nests up here would be super, and the pools or something that are in the center are toxic one-toned blue that has no texture. I thought it was odd to have the mailbox outside the place. Surely the spiders would have nibbled on it. Also, what is stopping spiders from infesting this bunker? There is no sign of them down here.

    Outside, there are quite a few random bits of wall just standing around. These don't have any real reason for being here. If they used to be buildings, there would be more remnants of other walls adjoining them, but each wall section is only single, and there is no sign of flooring, broken roof or basements, or indeed bits of fallen over broken wall.

    Environment: Dream Hive
    Amazing! Love the look of this! Finding the passageway and then finding the tunnel down here was exciting, and then to come into the large chamber was great! It was one of those moments where you pause to take it in.

    As it is, when I first came down I could see across to open sky where the area isn't blocked in long distance. It took actually moving past the quest npc into the room more for the area to finally load properly. It looks even better! This place is amazing to look at, and I think the fact that there is nothing moving down here makes it all the creepier, because its times like that, when there is nothing small around that you know something BIG is around, just waiting, perhaps watching you even now. Freaked me right out.

    Oh, as a side note, how is it a spectral being can build a fire and keep it burning? And why has the ascended not asked that, or who this person is etc.

    Again, when coming back down to hand in 'Creepy Crawlies, the room doesn't load fully where the npc is standing, though I realized this was because I had it put on low graphics settings. Turning it up to high and the room seemed to load more. Still, if you moved the npc to the little glowly river the room would load fully for the low graphics people, though maybe you wouldn't be able to see her properly then.

    Carnage: Chopped & Scrambled
    Got all the spiders I needed, but was unable to actually get my reward due to the bug that stopped me completing 'Savory Survivors'.

    Creepy Crawlies
    I don't think there are enough of the spiders around here. There should probably be more. Doing this quest, linked with the carnage quest means you have to kill quite a few, and you are running around quite a bit to get them. However if, like me, you are under their level, having them grouped up too much might be difficult to survive. I am level 53, and they are level 55, and three of them killed me in about 5 seconds. Perhaps a quicker respawn time or something. Handed in fine.

    Into the Dream
    To be fair, I was wondering about the sanity of any ascended who actually went through with this quest. It seems to me to be highly suspect, especially from a woman with no body, and no sign of whatever put people in those cocoons.

    The quest text says "Head down the tunnel and place the venom in the fire" however it would be better to say "Head to that fire, and put the venom into it" or something, since the npc is standing pretty much right next to it. Again, I have to ask, how is that fire still burning if there is no one to feed it? She also hasn't, to my knowledge, told me how she was able to speak to me in the normal world while she was trapped in this dreamland. Perhaps I am just too suspicious by nature.

    Identity Crisis
    At first I thought 'oh great, now I have to go kill x number of things for people in dreams to, but this was actually fun. I especially liked the super jumping. In fact, that was my favourite part lol

    Child's Play
    I want that noble's coat! Costume item please!

    The Mentor
    Worked fine

    Animal Rescue
    Worked fine. I liked how the animals turned into something more ferocious once I had freed them.

    Environment: Arkella Estate (Dreamworld)
    I had thought that traversing this area in the dreamworld with the jump buff would make it far better, but not so. It is still limitlessly frustrating getting around in this estate, what with the various levels and dead ends. Rawr.

    At the center of the dome where you deal with the quest for 'vivisection interupted' there is a hole in the ground for the sourcewell. You can walk over it like it isn't there, or like it is covered, but it is still visible.

    Also, it would be nice if you got the speed buff constantly as well as the jump buff. The speed buff only seemed to work when you were shifted to someone else

    Vivisection Interrupted
    The quest worked fine, though for ages I didn't know what to do about the animals. I was down to half health when I noticed that a couple of the cages were sparkling. Might be better to have all the cages sparkling, but maybe have a cooldown as to how many you can open at a time to stop them all being opened at once, or let them be so.

    Down the Rabbit Hole
    When you come out of the dream, you are not in the place that you went in. It would be better for the quest to take you back to beside the fire where you left, and have to find the right egg using the mini-map and sparkles, or have the woman show you.

    The Wife
    Oh gods, not this town again! I loved the idea of the town and the style of it etc, and I would have liked to have seen it fully functional, but please, for the love of everything, please please make it more user-friendly.

    Actually, that one wasn't so bad. It was a direct run. I do like the personal courtyard style of things, I just find other areas difficult to navigate.

    On the Clock
    This was interesting. It might be good to have the questgiver tell you to run through the circles of mist for speed, because i thought at first it was the exit out of this second dreamworld and avoided it until I saw the second one. The speed circles also helped me find the best route, which I certainly needed in this town. Worked fine, and I got there on time. Huzzah!

    Hands off my woman
    This quest didn't work. When I took the quest, I was still in my shifted form of the husband, and I was watching the entrance to the courtyard for him to come, but no one appeared. So I turned around and suddenly the guy just appears in the wall. Firstly, he should really come in through the courtyard entrance shouldn't he? Second, he spawned, was the 'friendly' green, then turned the 'enemy' red for a second, hit me once and disappeared. Then reappeared green, turned red, hit me, disappeared and reset. This kept happening until I abandoned the quest. Taking off my costume didnt help, and I couldn't target him.

    I retook the quest, and the same thing happened again. So I abandoned it again and started to type this. Only then, with the quest abandoned, and me standing there doing nothing, did the guy appear and actually walk towards the woman and start taunting her. I quickly took the quest from her and killed him as expected. So, I did get the quest completed, but it is buggy as heck.

    Again, this quest moved me from where I took up the last dream. Would be better if that didn't happen.

    Family Secrets
    Completed fine

    Tower of Denial
    I had fun jumping up to the top of the tower, but it begs the question: How did she get up here? The tower seems the same as in the real world, so how was it used? All these platforms don't have doors on them to make them balconies. The lack of practicality in this building makes me sad.

    Soul of Guilt
    This was an easy one to complete compared to the other two. No jumping, no endlessly frustrating puzzles. Just grab the woman and through a portal.

    Law of Consequences
    Congratulations on making this frustrating town to even greater heights of computer smashing temptation. I put up my hands and say that of all the quests I have done and tested, I have never been this annoyed.

    1. It's difficult to judge just how far and what direction the guards will turn
    2. They turn with a speed that is faster than a normal guard would unless he hears something (in my opinon)
    3. Instead of actually helping you, the increased jumping actually is annoying as hell, because you can't judge jumping out from behind hedges as well as you could before
    4. The trigger on sending you all the way back to the start is very fine. I clicked the box when I saw the guard's range start to turn, and despite having clicked it in time, I still got sent back to the beginning again. RAWR! I also, on my screen, avoided the turning of the guard only to get sent back anyway, as if there was slight lagg on the effect or something.
    5. This little test forces you to do things a certain way. I really doubt I will ever be able to complete this blasted quest without smashing the computer, and there is no way to complete the quest, the story and therefore cannot continue the quest chain. This is bad. There are some people, like myself, who just don't like this sort of thing, or who, also like myself, are supremely crap at it. This means that those people cannot continue with the rest of the quests.

    I finally got this quest done, but I have to say, I did not enjoy it. I was very glad that there was a portal out of there when I got the disguise.

    Completed fine

    The Nightmare Ends
    Thank goodness, out of the dream world. Not as much fun as I thought it was going to be.
    EEEW!! That has to be one of the grossest mobs I have seen in a long time. I didn't realize that Savola could change people's gender as well as give them more limbs. I thought it might be a massive spider or something.

    Also, thanks for the Achievement. Many achievements I feel are just nice, but those quests really took a toll on me. I needed that achievement lol

    After the quest was handed in, the eggs were still clickable, not sure they were meant to be. I didn't let myself fully click them, didn't want stuck in there, just in case.

    Next Step
    Completed fine, but where is this army she speaks of? Where are all these people? I see no one new, and this place looks as empty of habitation as ever.

    Last Entry, Final Hope
    I am slightly confused by this quest. It wasn't there before the dreamworld quests, but I can't really think of what it is actually saying, as in the story and context. Why was the holovid not working before I went down? Although this says it is a holovid, nothing actually shows. Perhaps this is a bug, because holovids usually have a video hologram on them, hence the name. This would explain a lot. I expect this holovid is bugged. The quest however is not.

    Ah, upon actually accepting the quest, the holovid actually started working. This should start working when you first click the holovid because the quest refers to what was said in it, and makes little sense until you have seen it. I still see no reason why the ascended would not see that holovid before, a technicality, true, but still a niggling one.

    Looking for Group
    Useful that she needs me to go to the same place and see the same person as the holovid wanted me to lol. Still, there is no way mentioned how to actually get to this place, or where it is. I am guessing going back through city core and find a way from there.

  10. #10
    Update: Savory Survivors
    This quest completed fine when I logged out and in again. Not sure why it didn't complete before, so I would still think it needs looking at.

  11. #11
    Quote Originally Posted by quietscribe View Post
    Update: Savory Survivors
    This quest completed fine when I logged out and in again. Not sure why it didn't complete before, so I would still think it needs looking at.
    Just to piggyback; I've had a couple carnage quests do that as well. If you finish them, click the reward box and finish....it just closes the reward window, and doesn't give you the reward. In all 3 cases where I've encountered this, logging out and back in fixes it. I /bugged in game as well.

  12. #12


    Eastern Holdings quests cont

    Carnage: Only so Vhar
    Completed fine

    Carnage: Vile Guards
    Completed fine

    Carnage: Mutant Devastation
    Completed fine

    Carnage: Mutant Infestation
    Oh, how I hate ranged mobs. Completed fine though.

    Arkella Tales
    Completed fine

    Holovid History
    Completed Fine. I would point out though that the Chancellor's tower doesn't have any entrance for him to come and go as far as I can see. This has been happening a lot with towers. Especially when a quest points out a house, you might want to think about how a person would get in and out of that house.

    Carnage: Fight to Survive
    Nice fast respawn time on these thankfully. Would have run out of them otherwise. This was a good easy quest because they were easily gathered, no troublesome casters.
    Completed fine.

    Carnage: Blood in the Water
    I am not a big fan of killing things in water, but at least you could just about pull three at a time, which was a saving grace.
    Completed fine.

    Carnage: Clockwork Men
    I didn't mind these ranged mobs so much because they look so obviously different to the melee ones that it made it easier to target where I would take the fight. This carnage worked particularly well with the other carnage in the area: Jeepers Creepers.
    Completed fine.

    Carnage: Jeepers Creepers
    Easy to kill, so was good fun gathering tons of them. I also liked how they swarmed, since it made it easier to gather.
    Completed fine.

    Troll Banners
    Completed fine.

    Carnage: Rognatt
    A nice surprise of a quest when doing the banners one since he was standing in front of it.
    Completed fine.

    Carnage: De-mossing the reservoir
    I liked the fact that there were no ranged mobs. All of them could be gathered. I have simple pleasures like that lol
    Completed fine.

    Teleport Tally
    This quest completed fine.
    This quest completed all the story quests in the region of the eastern holdings, and I have to say I am surprised and a bit disappointed that I am not even 'friendly' with the Eternal City Survivers (2975/3000). Considering how much I have done for them, I think that you should end up as at least friendly by the end of this quest chain. Bit of a slap in the face otherwise from a story point of view, and a bit disheartening from a game point of view. I think more rep should be given for quests involving factions, especially here.

  13. #13


    Just found this quest while trying to find the correct way into Ardent Domain.

    Completed fine. The handin was amusing.

    Carnage: Mutant Macification
    Completed fine.

    Carnage: Scattering the Scarabs
    Completed fine

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts